Some images will not decode two channels simultaneously (unless they are on the same transponder) to allow watching of one encrypted channel whilst recording another (on different tuners). This is because they do not allow opening of two CA devices.

The fix in OpenAR-P 31.03.13 was to edit the 60-dbd-ca.rules file as follows (info from another post on this site):-

Code:
# /etc/udev/rules.d/60-dvb-ca.rules

##swap ca0 <-> ca1
#Original
#KERNEL=="dvb0.ca0", NAME="dvb/adapter0/ca0", SYMLINK+="dvb/adapter0/ca1", MODE="0660"
#KERNEL=="dvb0.ca1", NAME="dvb/adapter0/ca3", MODE="0660"


#New
KERNEL=="dvb0.ca0", NAME="dvb/adapter0/ca0",MODE="0660"
KERNEL=="dvb0.ca1", NAME="dvb/adapter0/ca1", MODE="0660"
-----------------------
The fix in the latest PKT Hyperion image is to set the EMU manager to:-

'Mapping CA1 to CA0 - Enabled'

---------------------

I have now worked out to do this in latest RSP rc1 image too.

We need to enable the CA device ca2.
Do this by running two cmds in telnet.

Code:
mknod /dev/dvb/adapter0/ca2 c 212 22
chmod 666 /dev/dvb/adapter0/ca2
To save typing in these cmds every time the image is restarted, they can be put in one of the boot start scripts.

I'm sure this is not exactly the correct place, [ I think it should actually be /etc/init.d/rcS ] but I put them in the RSP panel start script located at

/var/config/start.sh

I created a few new lines at line 38 and C&P this

Code:
#Create CA device ca2 for dual decoding
mknod /dev/dvb/adapter0/ca2 c 212 22
chmod 666 /dev/dvb/adapter0/ca2
After a full hard reboot, device CA2 is present and working.

Code:
RSP:~# ls -l /dev/dvb/adapter0/
crw-rw---- 1 root root 212, 1 Mar 9 07:47 audio0
crw-rw---- 1 root root 212, 6 Mar 9 07:47 ca0
crw-rw---- 1 root root 212, 6 Mar 9 07:47 ca1
crw-rw-rw- 1 root root 212, 22 Jan 1 2000 ca2
Thus dual decoding is automatically enabled. :)

Of course this only works if you are using oscam and can legally decode the channels in question. ;)